Microsoft Edge is not working correctly for admin users
Incident Report for Inspera
Resolved
This issue is now resolved.
Posted Apr 29, 2018 - 10:36 CEST
Identified
We are now ready to test a solution. If everything works as expected, we will deploy the solution as soon as possible.
Posted Apr 23, 2018 - 15:26 CEST
Investigating
We are currently investigating the problem. If you have trouble using Edge in Inspera, please switch to Chrome (recommended) or Firefox.
Posted Apr 20, 2018 - 12:16 CEST