Inspera phone lines out of service
Incident Report for Inspera
Resolved
This incident has been resolved.
Posted Dec 11, 2018 - 07:59 CET
Monitoring
Inspra phone lines are back in service. If you still cannot get through, please use Service Desk to report issues.
Posted Dec 10, 2018 - 13:12 CET
Identified
Please use Service Desk to contact us. We are monitoring incoming issues continuously.
https://inspera.atlassian.net/servicedesk/customer/portal/1
Posted Dec 10, 2018 - 09:41 CET
This incident affected: Inspera Assessment Help Center.