Issue with student responses on tests that were active during the weekend
Incident Report for Inspera
Resolved
We have now completed the automatic restoration of submissions.

Remaining support tickets will be processed manually, and you will hear from us as soon as we have updates.

If you have any issues following this incident, please contact Service Desk.
Posted Mar 16, 2020 - 10:08 CET
Update
This update applies to tests with auto submission enabled.

The issue in the previous update is now resolved, and candidates can continue on their tests until the test closes. Their responses will be submitted when the test closes.

Please contact Service Desk if you require further assistance.
Posted Mar 13, 2020 - 14:51 CET
Update
Update for tests with auto submission enabled.

During the automatic restoration, a number of tests and candidate responses were submitted automatically even if the test end time had not passed.
We will restore the previous status this afternoon.

The workaround until the fix is in place is to open for resubmission manually. Please note that this action also requires that you close resubmission manually when the test ends, as the automatic submission feature does not apply to candidates who are open for resubmission.

Please contact Service Desk if you require our assistance with the workaround.
Posted Mar 13, 2020 - 10:07 CET
Update
The second round of automatic data restoration is now completed with good results.
We will continue to check and verify reported tickets.

Please contact Service Desk if you have any questions, or if submissions you expected to be restored are not visible.
Posted Mar 13, 2020 - 07:46 CET
Update
We have completed the first round of automatic data restoration, with good results. The majority of submissions are now visible.
We will check all reported support tickets and respond to them throughout the day.

The analysis of impacted data will continue today and tomorrow.

Please contact Service Desk if you have any questions, or if submissions you expected to be restored are not visible.
Posted Mar 12, 2020 - 08:20 CET
Monitoring
There has been good progress on analysing data, and in developing restoration tools. We are planning to do the first round of automatic data cleanup after business hours tomorrow (Wednesday).

The original plan to have completed this work by the end of the week is still valid.

Please contact Service Desk if you have further questions.

We will post an update to this incident if there are any changes to the current plan.
Posted Mar 10, 2020 - 15:32 CET
Update
The fix was deployed as planned yesterday evening.

We will continue to thoroughly analyse the data today. The analysis will identify all the potentially impacted submissions. Once the analysis is complete, we will start restoring impacted submissions.

We expect the work to be completed at the latest by the end of this week. Notice will be given when the work is done.

Please contact Service Desk if you have further questions.

A new update will be posted latest 16:00 (UTC/GMT + 1) today.
Posted Mar 10, 2020 - 08:34 CET
Update
We will deploy the fix at 21:00 (UTC/GMT +1) tonight as originally planned.
Please note that the fix will not in itself restore the submissions, it will only correct the root cause of the incident.
We will continue the work to restore submissions during the coming days.

There is no loss of data, and all submissions will be restored.

For tests that have a start date before or on 06.03.2020 and end date on or after 07.03.2020, we recommend that the grading is postponed until we have verified that all submissions are restored.
Some tests with a duration of only today may also have been affected, and candidates may have missing answers. These will also be restored.

We will update this incident tomorrow with more detailed information about the schedule for restoring data.
Posted Mar 09, 2020 - 15:58 CET
Identified
During this incident, we recommend that you do not use the "open for resubmission" feature.

Those candidates who have started a submission during the period from 06.03. and until later this evening, but not submitted directly after finishing, may be affected by this.
It may also affect those who started a submission before 06.03. and then continued on the same submission after this day.

A fix is ready and will be deployed tonight at 21.

After the fix is deployed, we will continue the work to restore all submissions. Please note that the submissions might not be visible immediately after the fix, but they will become available as our work progresses.

No submissions are lost due to this incident.
Posted Mar 09, 2020 - 12:58 CET
Investigating
We have identified an issue with tests that were in active status over the weekend.

This applies to tests that have a start date before or on 06.03.2020 and end date on or after 07.03.2020 (tests that were active during Friday evening).
The consequence of this is that student submissions are not visible/available. We are working on correcting this issue.

IMPORTANT! If you have any tests that match these criteria, until further notice, please do not open for resubmission for any candidates who have submitted.

Candidates on tests that match these criteria might find that their answers are not visible.

A new update will be posted before 13:00 (UTC/GMT +1).

Please contact Service Desk if you have any questions.
Posted Mar 09, 2020 - 11:39 CET
This incident affected: Inspera Assessment - Student.