Print and download of submissions/question sets is currently out of service
Incident Report for Inspera
Resolved
The service is now restored, and print and download is available for both submissions and question sets.
Posted Feb 08, 2021 - 11:00 CET
Investigating
We are investigating the problem and a new update will follow as soon as possible.

The problem affects print and download of submissions, as well as download of question sets.
Posted Feb 08, 2021 - 09:50 CET
This incident affected: PDF Service.